Amazon Fire Tablet - Won't Start HAMRS


New HAMRS app user here. Just purchased versions for both Kindle Tablet (Fire 8 2016 model) and my Android phone (Pixel 4XL). The app started up as expected on the phone.

However, on the Kindle tablet, it just shows a white screen. I’ve tried force stops, clearing cache, uninstall/reinstall, reboot tablet, etc. without success.

Has anyone else run into this?

Thanks 73
Pat n0hr

Updated the Kindle. (latest version Fire OS No luck. Then factory reset (removes all apps and settings). Reinstalled. Still no luck.

Has anyone had luck getting this to work? Avoiding dragging my laptop to the field.


I’ve successfully run HAMRS on 2different Fire Tablet 8s. I’ve not experienced your problems. But both of my FTs are dedicated to HAMRS.

How much do you have loaded on your FT? Music, photos, books, etc. The FT processor and operating system are far from robust.

Mine takes 2-3 minutes to load HAMRS and after 50 or so saved logs it will get very slow. But it does work on mine.

Hopefully you will be able to get things worked out.

Good luck!

Jack. N8EU

Hi Jack,

Thanks for the reply. I’m glad to hear that it’s worked for you.

My Fire tablet has nothing else loaded on it other HAMRS. I haven’t downloaded any music, photos, videos, etc. This afternoon, I did a hard reset (power button + volume button) to clear it, then only installed HAMRS. No luck.

There’s 8.5 GB of free internal storage. No SD card installed.

I’m about to give up on this route. My dilemma is… what should I use instead for a low cost, (non-Apple) POTA logging device? I’m tempted to just get another Fire tablet, but it seems to be an unreliable platform for HAMRS given my experience and performance issues I’ve heard from others. Are your Fire tablets very old models… would a new one with more RAM help the performance issues?

Pat n0hr


I’m no expert with any computer platform. But I have HAMRS running on a PC, iPad, MacBook, iPhone, and 2 Fire Tablets. I’ve not had any particular problems with HAMRS on any of them.

My newest FT is a FT8 (10th generation running the latest operating system). The other is an older FT8 (6th generation).

The newer one has 32GB memory with 22.5 GB free. The older one has 22 GB free.

When I first open HAMRS, I get a white screen for a minute or two. It loads slowly. Be patient. But then it has been stable for me. I have a bluetooth keyboard for it, but it’s a cheap one and it was keyboard issues, not the FT, that prompted me to buy an older iPad. Probably a better bluetooth keyboard and I’d still be using it.

Suggest you try downloading some or other free app from the Appstore to see if that one will successfully download and run. If so, you can delete it.

I’m running 1.0.6 HAMRS (latest version) on my FTs.

Sounds like you’ve done the correct things so far. I don’t have any further suggestions for you. Hopefully someone with Android experience will jump in here. All I can do is assure you that the FT will indeed run HAMRS very well.

Hang in there.

Jack N8EU


What icon for HAMRS is on your FT?

Is it orange with Amazon Fire inside a square, or is it blue hash marks with HAMRS inside the square?

I just tried to start my old FT–the icon is orange Amazon Fire in the box with HAMRS underneath. I won’t load either.

The correct one is the blue one, on my newer FT, and it loads just fine.

Not sure what the solution is yet, but I’ve duplicated the problem.


Jack N8EU


The app on the homepage is the green generic android app alien icon (as seen on the wikipedia page for android OS). If I open settings/apps, “Manage All Applications”, I see it with the orange “Amazon Fire” square icon.

I’m wondering if the issue is HAMRS not running on the Fire tablet OS (Fire OS 5.6.X) for these older devices. In my attempts, I haven’t seen the proper HAMRS blue square icon on the app screen.

So, as a last resort, I’ve ordered a new Fire tablet. Amazon has a trade-in program, so I’ll get 20% off + $10 for trading in this old one. I guess I’ll see if that works.

Thanks again Jack,
Pat n0hr


I’m wondering if that orange icon with HAMRS beneath it an indication of the problem. The proper icon should be the blue hashes like at the top left of this page.

In the meantime, HAMRS won’t load on my old tablet either.

You may be correct that it could be related to the age / generation of the FT. This is the first I tried to start my old machine in over a year. I’d be interested in hearing what happens.

BTW, a bluetooth keyboard will make logging a whole lot easier in the field.

All the best,

Jack N8EU


After playing around with my tow FTs, the new one runs HAMRS and the older one will not…

The older one, generation 6, Is running OS and will not update to versions past OS 5.

My newer one is running OS and was updated yesterday. This one does run HAMRS.

Check to see if your FT is running as OS 7 version.

About the time HAMRS generation 1.0.0 was released (now into 1.0.6) it required a later OS for several platforms.

I expect that a newer generation of FT that will run OS 7 will also run HAMRS. Hope this gives you a better perspective on your problem.

All the best,

Jack N8EU

Just a follow-up on this…

Ordered a new Fire tablet (HD 8, 2021 edition) which arrived today. I immediately installed HAMRS and it worked as expected in my initial tests. Made a few test QSOs and it worked well.

So, it’s clear to me, that the older Fire tablets (with OS 5.X and prior) are simply not working at this time (and perhaps won’t be supported in the future).

I’m trading in my old Fire tablet as a 20% credit + $10 toward the upgrade to the new one.

73 Pat