Delete QSO on 11.0 Beta

11.0 on my iPad. After an activation, I had a DUPE.
Click to the right on the log, Delete, and I get the warning that it can’t be undone.
Hit OK…and nothing happens.
Tried several times.

The latest beta of 11.0 has fixed this issue.

This has been identified several times during beta but the bug persists in the final release.

It existed in every beta release since (4), at least on the iPad.

Are you sure the final release is out for download? I don’t see it as an option to update in my account.

Yes, it is. Go to and click on that link.

@KD2E - I can’t seem to replicate this issue with the current build. I’m still looking around but would love confirmation that yes, in 0.11.0 released today it is still broken for

I posted in the beta category… for me, if the QSOs are logged using HamDB as a resource, I can’t delete them. If HamQTH is used, I can.

I looked again, and agree with KZ3L. With the two additions. resource = cannot erase
Copy from the POTA Spots window = Can erase.


Rescind last note. Still cannot delete QSO, except entered by POTA Spots, or Ham QTH.

Regarding delete function. I had installed 11.0 on Win 10 PC, and noticed I could not delete QSO’s…just like iPad version. I shut the program off, restarted …and it worked fine. So, I thought perhaps iPad version needs a shutdown also??? I closed the program and restarted it, and was able to delete qso’s. But adding more qso’s, I ran in to problems deleting again. Shut off the program, restarted…and again…I was able to delete them. Very weird!!!

MacOSX 10.15.7 HAMRS 0.11.1

Hmm, I’ve just entered a couple of dummy QSOs into my test logbook. I find them in the list. I go to the gear icon, click on it, then click on delete in the menu that pops up. A warning box appears. I click on ‘OK’ to perform the delete. Nothing happens. So, this bug has reappeared.


Andrew, N1ACW

Which lookup service are you using?

I posted this:

Some more information on my findings. Although I cannot delete QSOs during the session that I entered them in, if I restart HAMRS, and try deleting them again, they then are removed from the QSO Entries list.

Hope that helps! N1ACW

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.