Many QSO records lost in a logbook between invocations of HAMRS

Yesterday I had 132 records in one of my logbooks. Today, in that same logbook HAMRS is reporting just 52!! I know this because I dump out a .adif file most days to upload to LoTW. The last .adif I exported was from July 27th for the logbook in question.

I upgraded to 0.11.0 on my Mac yesterday. The bands were terrible, so I hadn’t added any QSOs. The only thing I did was to add in my credentials and perform a ‘Lookup All’ on the QSOs in this particular logbook.

Is there a way of checking where the missing QSOs have gone? Can I inspect the back end database in some fashion to check?

Andrew, N1ACW

Oh, I’ve just read the release notes and fixes for 0.11.1 - I see that you fixed a bug that caused QSO deletions when looking up info in Could this be the same problem?

That release note was specifically for NOT being able to delete QSOs that had been looked up with, until you closed down the app completely, and came back to them, so I don’t think that’s your issue.

Have you tried completely closing HAMRS, maybe even doing a restart on your machine and seeing if they’re there?

Hello Jarrett,

I’ve just reset my Mac (it’s been up 150 days) and still no luck. The QSOs are not shown in the HAMRS interface.

Are you using sqlite for the DBs? If so, I could take a look in them to see if the records are actually in the database still.

Note that the problem is only with one logbook out of about 20 I have. It also happens to be the one that I tried to ‘Lookup All’ from QRZ in. I’ve not done that in any of my other logbooks within HAMRS and they are all fine.

Andrew, N1ACW

@N1ACW Jarrett mentions in another post that he is using a “NoSQL DB that lives in IndexedDB inside of the app’s framework”, so it’s not SQLLite.

Okay, Kevin. Thanks. That’s a bummer. Unfortunately, there’s no easy way into an IndexedDB database to take a poke around since it’s really designed for Javascript access via a browser rather than being multipurpose.

Similar issue I reported first week of July can be seen here. Still have heard no word back that would explain it. Using an iPad when the issue was discovered. Good luck. Hope you can recover the lost QSOs. I wasn’t able to recover mine.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.