MEGATHREAD: QSO Map not populating / Grid Issues

There have been a couple of reports of the map not working. I wanted to start a megathread to consolidate the topic and see if there is a ‘there’ there.

  1. looks like it’s having its grid issues again. Please make sure you are using QRZ or sign up for HamQTH. I really like hamdb as a default free option, maybe @KK6NLW can shed some light on what’s going on there.

  2. There is some bad UX to be aware of - if you’re using hamdb (the default) at the moment, and you enter your credentials for another service, HAMRS doesn’t automatically switch you over to using that service. You’ll need to make sure you click ‘Settings’ and then choose your new lookup provider from the dropdown.

  3. If you’re on the latest build (0.11.2 at this time), and are receiving ‘UNKNOWN’ as a grid square from a lookup - please let me know:

    • Which provider you are using, and
    • If you’re using QRZ, do you pay for the XML service?
      I haven’t been able to replicate this issue.

If there is anything I’m missing let’s consolidate the conversation here so I can make sure I’m capturing everything.

Oof! Calculating grid squares requires converting street addresses to lat/long. I had switched to a new geocoding service that provides this function but it looks like with the growing number of requests going to HamDB we’ve now exceeded the monthly limits of that API:

“You have exceeded the number of monthly transactions included with your current plan. If you need additional transactions, please consider upgrading to a plan that offers additional transactions. If you would like to talk to an Account Manager about Enterprise Edition licensing options…”

Let me see what I can do in short term to get it back up and running. Long term I’ll likely need to build in a caching system and a fallback system to auto-switch geocoding services when one fails.

Give me a few hours and I’ll get something worked out short term.

@Jarrett - it’s returning grids again, I’ll build out a more robust system this weekend. Thanks for stress testing HamDB :wink:


You ROCK! Thank you so much, I really like having hamdb as the default option. If there is any way I can help out, I’m not sure what it’s written in, let me know!

1 Like

Additional data. Logged a contact today on 3 devices. An iPhone, iPad and a PC. All 3 had my grid info properly entered, but only the IOS devices properly showed my location on the QSO map. The PC still showed my location as Wichita, KS.

@w8drp Out of curiosity, did you enter your grid square before entering any QSOs? And if you enter another newer QSO with your correct grid square, does it move your QTH pin to the right spot?

I’ve found that if I enter a QSO before entering my grid square on my Windows PC (left it blank), in the POTA template, HAMRS places my location pin in KS by default. But if I then enter my actual grid square and a new QSO, HAMRS moves my QTH pin to this new grid square location. It leaves the others untouched, and the map shows all QSOs as having occurred from the latest grid square entered.

As an aside: In my opinion, having some static information (such as my grid square, my state, etc.) would be best – change it once and it changes every log entry for the current logbook. But that isn’t the way HAMRS works at the moment. As designed, I can enter different grid squares for each QSO if I wish and it uses only the most recent one to represent my location on the map. To me, that isn’t very intuitive.

When I saw the KS default, I immediately checked my grid info and it was already correctly populated. Then I checked the iPhone and iPad, and found them to be displaying correctly.

Doing QRP today in the field, using an iPad, and a HAMRS logbook, that had been properly showing my home QTH on the map had defaulted to Witchita, KS. Even though the qso’s were saved and still have my home qth grid info? Then upon returning to my home qth, the qso map began showing my correct home location. Hard to understand.
Hopefully this is helpful info!
Don, w8drp

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.