QRZ Upload No Records

I export my logbook to load into QRZ.
I imported into QRZ.
I have 17 records failed to import.
Using the Generic template
iOS iPhone here.
Can’t see how to upload my file here.

Email from QRZ:

QRZ has completed the import processing of your logbook file.

File name: ka9rcm.319850.20220206052505.adi (0 records)

Destination Book(s):
“KA9RCM Logbook” (319850)

Started on: Sun Feb 13 06:23:58 2022
Finished on: Sun Feb 13 06:23:58 2022

------------------------------ Book Breakdown --------------------------------

Book: “KA9RCM Logbook” (319850)

Import Results:

0 QSOs were inserted
1 duplicates were replaced
0 duplicates ignored
0 errors.
0 queued for confirmation checking

System Messages:


---------------------------------- Notes -------------------------------------

Duplicates are determined when a match exists between the incoming record and an
existing record in the database where:

The two callsigns match -and-
The operating BAND is the same -and-
The operating MODE is the same -and-
The QSO DATE is the same -and-
The QSO Start Time is the same to the minute.

Duplicate Rules:

If the duplicate has not yet been confirmed, the incoming record REPLACES the existing one.
If the duplicate is of a confirmed record, it is IGNORED.


The QRZ Team

@KA9RCM I upload my logs into QRZ routinely and it works well, but I use another template.

Can you email a copy of your ADI file to me? I’d like to see if anything odd jumps out. My email is my call sign @arrl.net.

Most of the time, missing a frequency, call sign, band, date, or time are the culprits. Entering any of those in the wrong format can cause problems with QRZ, too. I assume all of these fields are in your QSO entries?

It’s also possible the Generic template isn’t exporting correctly. Reviewing your file will help

If you want, you can also simply open the ADI file with a text editor and copy/paste the contents into this thread.

EDITED/ADDED: It seems odd that QRZ didn’t report errors with the 17 records you indicated were not imported. It did import one record as a duplicate, which suggests you’ve tried to upload this file before. When you view your ADI file with an editor, are there 18 QSOs in the file? Or only one?

You can drag a file to the area you are typing in to upload it here so we can see it, or click the icon of the ‘Picture’ to start and upload:

Screen Shot 2022-02-13 at 9.09.07 AM

Ok. Here is my file.

I’m on an iPhone so I can’t drag the file into this box or use the image option as it won’t let me select the file.

Here is a link from Apple Cloud to my file:

@Jarrett I think there is a bug in the Generic template export. It is inserting “undefined” immediately before the <my_gridsquare:6> tag, as you see below. It’s probably the contents of a field (“undefined”), when a lookup didn’t capture something properly, but without the appropriate ADIF tag to accompany it.

I guess that suggests two errors in the Generic template: 1. Missing ADIF tag, and 2. “Undefined” should translate as BLANK in any field retrieved from a lookup database.

I don’t know if the same error exists in other templates.

Thanks to @KA9RCM for reporting the problem.

I can replicate this by leaving out MODE. Can you confirm?

Ahaaa! Yes, that must be it. I was able to confirm the same result.

And it makes sense… mode fits alphabetically between gridsquare and my_gridsquare.

So how long will this take to fix and be updated on the App Store?

Just curious how long does it take to have an issue fixed? I’m new and want to get my logbook uploaded to QRZ. Trying to decide if I want to use this app or QRZ directly. Thanks!

Glad we were able to fix this for you with a search-and-replace in a text editor.

If anyone else is running into the same problem, please ask–I’ll walk you through the way to fix it until the bug is addressed in HAMRS.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.