QSO map on iOS don’t update with newly added contacts

I recently started a POTA log and it populated the five contacts correctly. Today, I added four more contacts, but the QSO map did not update to reflect the new contacts.

Several things to consider:

  1. Were you connected to the Internet?

  2. Is the grid square for each of the 4 additional QSOs populated? And if not, when you tap on the gear icon next to the QSO and choose ‘Lookup”, does the grid square get filled in for you?

  3. What lookup service are you using? QRZ.com tends to be the most comprehensive but requires a paid subscription. The other two are hit-and-miss depending on the country from which the other party is operating.

-Similar situation last night, 10/25/22. Only
One station populated in the app. Running IOS, ver.16, iPhone 11 max.

-I had internet service, and the current database is Hamdb.
How do you switch to QRZ? I have a paid subscription but it won’t let me switch to that service in the app.

Jason WV3V

1 Like


It’s possible HamQTH was down while you were operating.

Have you entered your sign-in credentials for QRZ in your profile? When you do this, if the credentials are correct, both should display with green checkboxes, like this:

Then you can switch lookup services in the settings.

Same issue here. On my ipad I am able to see maybe 10-20 of 100+ contacts in the log. IOS 1.0.6 with qrz lookup and good internet connection. All green lookup indicators. Cheers

And you are a QRZ.com premium (paid) subscriber? If so you might want to refresh each log entry to retrieve the grid square.

1 Like

OK. I get it now. Thanks KZ3L. No need to explain further.

For others:
In my situation what I saw were contacts for park to park contacts. And this Grid info comes from the park information. Not QRZ. And names and location info on the main form will be available with a basic subscription to QRZ. But not the grid info for the map.


1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.