Wrong location on QSO map

Hi, Jeff. First off thanks for developing this software. I really haven’t had much time to test it out because I’m restricted to mobile operations, the weather here is starting to improve. Anyway I was running a few test calls in the general template and checking the QSO maps and found that my location was in Witchita ?? I’m located in New Brunswick, Canada. Where is the program getting this info? My grid square in FN77do. Thanks again and 73, VE9ZZ

Same thing happening to me on my iPhone.

The same things here. I live in Brazil and my QTH appears in USA.

Thank you. I thought I was the only one experiencing this. I’m sure Jeff will look into it.

This is likely a dune of bug 632

GPS location is coming in the next release and will make all of the grid guess work I’ve had to do in the past obsolete :wink:

Great program - using on my 8" Android tablet for portable operation. Two questions;
Question #1 The map shows my QTH as near Witchita, KS when my Grid Square (on QRZ.com) is EM20 - Livingston TX and my current operating location is EM76ip - Dale Hollow Lake State Park Burkesville, KY. Where does HAMRS get the operating location from so maybe I can fix it?

Question #2 When entering the call of a worked station, I often see 2 or more operators names and addresses under the same call. After a few seconds one or more will drop off. I just hope the correct one is the one that fills the log. Why does this happen. When FCC reissues a call sign, I wouldn’t think the old would stay in the database?

Thanks again, looking forward to your reply
Herb - WB8BHK


The map Starts off centered on the US. Once you enter a gridsquare or Park identifier it should adjust.

Regarding number two - when I originally wrote HAMRS it wouldn’t do a QRZ lookup until you tabbed to another field, because then I’d know for sure you were done typing. Some folks didn’t like that because if you never filled in anything else in the form, and just hit enter, it would never display the information. So now as you type, it sends a request to QRZ and if you type slow like I do, it can show you different people - so if I type KB0IC and then pause for a second, it assumes you’re done typing and fires of a request to lookup the call, then displays the pop-up, then you type the final T of KB0ICT, and it will fire off again.

I need to address this because it seems to be bugging everyone. I can increase the delay, but then you’re waiting longer and it’s still not guaranteed to not double up on you.

1 Like

Jarrett, thanks for the quick reply. It worked … I entered my grid square (and corrected my park from k1278 to k-1278 and then the mapping function found me in southern KY.

This works for the POTA template, but I don’t see where I have an opportunity to enter my grid square n the generic template for general logging. Am I still missing something?

Maybe I need to download a later version? I am using version 0.10.4

As for the multiple calls, I agree that it would be best NOT to increase the timer, let’s let the system work as best it can to provide the info without delay.

Thanks so much for your great work!

I noticed that my map location stays in Kansas too using a generic logbook. Even if I edit a QSO and add my grid.

Using POTA log, my location seems to stay in when I enter my grid.

Running Android.

I just noticed this with a SOTA log yesterday. I was up activating a peak in NorCal and the map shows me in Kansas.

Use the “expanded version” and there will be an entry box for your grid square. At least there was for me.

1 Like

Same thing here.


The generic template doesn’t appear to display “My Grid” in the expanded mode. @Jarrett I think this is a bug.

@W6CMS “My grid” is an available field in the SOTA template when the expanded mode switch is on. Enter it and the map should work correctly. If you’ve already entered a bunch of QSOs, you can edit each one and enter your grid square in each.

I’ve been trying to figure out how I mis-configured it. Misery loves company.