ADI export link

Cannot find link to export adi file. Where is it :wink:

On the logbook page, you:

  1. Click the Gear Icon of the logbook you’d like to export
  2. Click ‘Export .ADI’

I need a little help on this, I see where to select the ‘export.ADI’

I logged over 100 QSOs on my iPhone today and after I click export, nothing else happens - where do I find the file? where does the export go to?

Thank you!!

Make sure you are on the latest build , 0.10.1, and completely close the app and re-open it to clear the bug. Let me know if that doesn’t work. Also, what OS are you on? Sounds like mobile?

Yes, was using mobile app on iphone. I am currently on SW ver: 14.4.2

Did closing the app and opening after the 0.10.1 upgrade work?

Hi Jarrett,
I restarted the app a couple times last night and this morning I restarted my phone and I am now able to see and save the adi file - Not sure why closing the app and reopening didnt do the trick but restarting the phone did the trick!! (most likely a operator error… :sunglasses:

which I should be able to submit as a log (I manually transferred the QSOs last night… I wont do that again!!) Thanks - look forward to giving this a go on the next activation/use.

1 Like

It wasn’t an operator error. The was a bug in the function that scrubs the the logbook name to convert to a filename. It was fixed in 0.10.1, but for some reason take apparently a full cycle to get it in place. I’m glad it’s working for you!

1 Like

I’ve had issues with getting my adi file to export to LOTW. So, I loaded it in my N1MM logging software to try to export it to LOTW. After importing to N1MM, I found that there were too many digits in the frequency column, and this is what causing LOTW a problem when I tried to export to LOTW. But, also, LOTW would not accept the HAMRS adi file. I’m not sure whether the export to the N1MM software was incorrect or if the HAMRS software was doing it. I really like this software, it’s very easy to use, but all this extra work is not good. I will gladly be a donor but something like this shouldn’t be so difficult. Again, not sure it’s HAMRS issues or LOTW or N1MM. Thanks to all, I really appreciate all that you are doing. 73 de WJ5K Rob

@wj5k Rob, I have a couple of questions for you that might help track down the problem, if you don’t mind:

  1. What error does LoTW report when you attempt to upload with TQSL?

  2. Do you have TQSL set to override location data from your file, or do you create a new Location in TQSL before uploading every time?

  3. If you create a new location every time, are you ensuring that the grid square, county, and state you are entering into HAMRS match with your LoTW Location settings?

If you could, please send the problematic ADI file, exported directly from HAMRS, to me via my call sign at I’d like to take a look at it to see if anything jumps out at me.

I always import my HAMRS data to my Windows logging app (Log4OM) and upload to LoTW from there, but I have tried uploading directly to LoTW in the past and it worked fine.


Looks like we got this sorted out…

For anyone struggling to upload to LoTW, please make sure you are entering your frequency in MHz. That is what the ADIF specification requires and it will not work otherwise.

1 Like

Thanks, Kevin. The last problem I had was mine, with the frequency issue. But this one I can’t figure out. I will send you my file from this activation. Sorry for always having issues.

I have never entered a grid square in my HAMRS software, just leave it blank. Do I need to put a grid square in there? All my activations have been within my home stations grid.

Thanks, Rob

Yes, feel free to send it–will be glad to take a look.

Did POTA accept your log? Is it just LoTW that doesn’t like it?

LoTW will accept whatever grid square, state, QTH, etc. you select if you choose the location override checkbox in TQSL or in the software are using (N1MM) to send the file to LoTW.

But if you don’t check the override option, LoTW compares the grid square set up in the LoTW location setting to the grid square in your log. If they don’t match exactly, it won’t let you upload.

ADDED: Received your email and replied.

@wj5k, I wrote up an explanation of TQSL and LoTW in your other thread. Please let me know if that helps – recommend replying in that thread.

I’m sure many others have experienced this with TQSL and LoTW, so hopefully this fixes your problem and theirs. :slight_smile: