Call sign database not working w/ Fire Tablet

I was out today using my iPhone for a mobile hotspot. My Fire Tablet was not recording state/grid squares of my contacts. This is version 0.11.1 The call sign lookup is not working either.

I tried it again when I got home with my home wifi and it doesn’t work here either, neither call sign lookup nor state/grid square.

I suspect my tablet isn’t making the connection to HamDB.

If I’m doing something wrong, what is it? Otherwise could it be a problem specific to the Fire Tablet?

Many thanks.

I have this same problem and when I enter a callsign it takes about 5 seconds for each letter/number to be entered. Then when I click on Save, the call sign disappears and the message “Callsign is required” pops up and no entry is made into the QSO list. If I go to POTA spots and click on copy for one of the entries, everything works normally.
Previous version was working fine.
73, Charlie - K0LAF

I will see if I can replicate this and get back to you here.
The each letter and number taking a while to show up sounds like an overloaded Fire issue, not HAMRS - are other apps’ inputs acting slow?

No problem with any other apps. Nothing that I know of has changed since the last time I did a POTA activation except the upgrade to version 11.1
Is there a way to roll back a version? I’ve never looked into that.
73, Charlie - K0LAF


KZ3L pointed out to me that I needed to enter my logins and passwords for QRZ and HamQTH into Profiles. States are being identified now and Lookup works. When it was on HamDB, no dice.

For previous versions the lookup and state entries were automatic and I didn’t notice the boxes for QRZ and HamQTH in Profiles. I’m not complaining. 0.11.1 is great. I especially appreciate the color change to green on the Spots when that station has been worked and entered.

I’ve not had problems with slow character entry on my Fire Tablet.


Jarrett, I just tried entering a call sign into the lookup entry box at the top and characters are entered as fast as I type them. Clicking the spyglass results in a correct lookup from

Ok, I cleared the cache and cleared the data and no change. I un/reinstalled the app and that fixed the slow callsign entry. However, still have no lookup and no entry of data into the database.
Charlie - KØLAF

Ok, I can confirm that something is up with hamdb lookups with Fire Tablets. I think I’ve isolated it. Can you update your profile with QRZ or HamQTH information and confirm that the error is isolated to hamdb?

On my tablet it is not isolated to hamdb. The first thing I did on this version was update my profile with my credentials.
Thanks for looking into this.

I’m no expert, but this worked for me.

Under profiles (you may need to start a new one) you need to enter your login and passwords for and You will need to go to these sites and register, if you have not already…

Next, under Preferences, you can specify which data base HAMRs should use to look up call signs. I don’t remember this selection feature on previous versions. Anyway, once I specified HamQTH as my preferred database, it started working as it did before.

Now I get the name and state once the qso call sign in entered in the field, states are populated in the Entries field, and I can use the Lookup feature at the top right and also via the Edit button.

Good luck.

I had already done this and I get no lookup with either or I could live with not have the lookup feature, but the real issue here is that the QSOs are not logged.
73, Charlie

I’ve got a build currently going to beta for Fire tablets right now. It should solve these lookup errors.

Thanks Jarrett. I have tried every way I can think of to break 11.2 on my fire tablet and it seems to be fixed now. Now, back to the parks.
73, Charlie - K0LAF

1 Like

So glad to hear it! Not gonna lie, Amazon threw me for a couple of loops I wasn’t expecting :wink:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.