Can not export adi file on iOS 14

Wont export the adi file on my device

Try to save file and it does nothing, try to save to Dropbox it errors out.

I never tried Dropbox Integration, it should just work. Does anything work? Airdrop or email for instance? Or is just 3rd party integrations not working?

I’m also having the same problem. I cannot export my Adif. Cannot attach to email?
Using iPhone 11 and iOS 14.4.2

I just tried exporting to Dropbox from my iPhone 11 Pro and it worked fine for me (iOS 14.4.2).

I have done all of them successfully. Everything works as expected on iPhone XS running IOS 14.4.2

  • Airdrop works
  • Email works
  • Dropbox works (though there is more info you need to enter, you need to tell it which folder in dropbox to share it to, and you need to give it an email address to alert… I just used my own email address)
  • save to Files works (icloud)
  • Messages works (texted it to myself)
  • Slack works (slacked it to myself)
  • Evernote works

Thank you for taking the time to test all of those out!

what is being described above seems like a file permissions kind of thing… i was looking into how it might be restricted on an iphone, if I come up with it, i’ll post here.

This may not be the answer, but searching for possible reasons iOS apps can’t export, I came across this in a Dropbox Support forum. The below answer was from Dropbox to a person who could not export files from Dropbox. I know that the problem is not being able to export TO Dropbox, but I feel like the suggestion from Dropbox may help with the issue… obviously do this at your own risk. Before doing any of this, I suggest doing a shutdown / restart on the phone. And also, it’s not a terrible idea to back it up (if you have that ability).

"If you’ve ensured that there’s no pending updates for our app on your iPad AND the iPad’s OS as well, I’d suggest that you tried clearing your cache to try to resolve this.

To clear your cache (on iOS), please follow the steps listed below:

  • Navigate to the “Personal” tab
  • Tap the gear icon in the upper-left corner of the screen
  • Select “Clear Cache”.

Once this is done then please ensure you log out of the Dropbox application again, then restart your device and log back in again.

If your issue persists, try another network if possible."

I might have found a future problem.

on my iPhone, it’s possible to create a logbook with NO NAME, I can bypass entering a name altogether. I select Parks On The Air from the dropdown, and hit Save. This creates a blank (NO NAME) Logbook line.

I was able to still email myself the no name file “.adi” in this case, however, I couldn’t airdrop myself a file, it looked like it worked, but no file was visible on my mac after the transfer. And I was still able to save to dropbox.

What I noticed in the OP’s original screenshot, is that the file export window just shows a date and time under the “file” section. On my phone, there is a filename (“trial generic” for instance) that matches whatever I named the logbook, when I go to export an ADI. I guess, unless the logbook is actually named “File Apr 02, 8 15 02 PM”…

@KD2TJU geez man. I owe you a t-shirt or something :slight_smile: If I had users like you at my day job, life would be EASY. Yeah this could be it. I definitely overlooked validating the log name field. I’ll add it to the next build.

Also, DM me your shirt size :slight_smile:

I’m having the problem.

Ok I had the same issue and did a little testing.

iPad with iOS 14.4.2

When I created the logbook I named it Crows Nest 4/10/21. I wasn’t sure if this would be an issue because of the / in the file name. It let me creat the logbook with no problem, add QSO’s. The issue arouse when I went to export the .adi file. When I tried Save to Files a blank window appeared briefly the disappeared. When tryin to email or send using messages they appeared but had no attachment.

Renamed file Crows nest 4-10-21 and everything worked fine. You probably need to add some validation to the logbook name to make sure the characters are valid for file names.

Workaround is to rename the file using valid character for file names. Unfortunately most people wouldn’t what that means or what they are or that they can cause an issue :rofl:


1 Like

yeah, disallowing illegal characters is probably a good idea.

I can confirm that I tried this test of changing the / with a - in the date format and I can now export my adif files via email.

1 Like

Awesome. Good to know. New build will replace / and spaces with - and _ respectively on export. You’ll still be able to use them in the logbook title, I just took care of removing them during export.


I had this happen on the first use of HAMRS on a 6th Gen 9.7 iPad running 14.4.2 and it cleared up by closing the app (app manager, swipe up) and then reopening. Then it gave me the usual save options screen. I sent the log by email and it worked just fine. Thanks for the cool app. Pete N1QDQ