Gear Menu's Not Working On Mac

Same issue as previous post… logs are locked up… no export, no edit, no functions of the gear menu whatsoever… the program is unusable … Mac OS Sonoma…

I discovered this after an activation today when I was unable to export. I am running MacOS Sonoma 14.2.1. From a previous post it looks like that update broke something. Any workarounds or suggestions are very much appreciated.

1 Like

Nothing worked for me to resolve it… sad day… : (

So, I went to the App Store on the Mac and downloaded RumlogNG… and good news is it’s actually pretty awesome! If you go that route, top right just below some of the contact details is a little “v”… click that and it will open the station details in a separate tab that you can size to fit the screen perfectly… only thing I cant get to work consistently on it is the full QSO map… IDK… but it’s pretty good… no pc version… only MAC… this will get you there…

1 Like

The alternative I used was to write a script that takes YAML input and generates an ADI file for upload to The source code resides here GitHub - sbostick/amrad-pota-adif: Managed by Terraform. If I get some time I’ll stand it up as a proper web app so it’s free and easy to use. Otherwise requires some knowledge of command line and possible Python code to use.

Now I need to generate a log in Cabrillo format for the ARRL VHF contest. Found a web-app for generating contest logs Cabrillo Web Forms although last updated almost 20 years ago. I prefer the command line and using text files and having the capability to augment missing data from I’m considering using a local cache of the raw data Daily & Weekly Transaction Files | Federal Communications Commission so the service can operate stand-alone (no subscription or external service integration necessary). I plan to add Cabrillo output support to my existing script instead of buying another app or learning another workflow.

It seems that functional or reference implementations for log generation, validation, conversion should be open source anyway considering the specifications are open.

I realize this doesn’t get HAMRS working for you on Sonoma but wanted to share my alternative method in lieu of a workaround.

1 Like

I have the sam issue on my MacBook pro with edit and delete functions not working with logbooks and QSO’s.
It does work on my I phone

I seem to have found a workaround to this. Within HAMRS, select HAMRS → Settings… from there set ‘Touch Alternatives’ to ‘On’. This has has re-enabled the gear menus throughout HAMRS for me.

Great find that definitely worked for me!!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.