How do I get the Map function to work?

Have the latest installed and really enjoy the software, however, how do I turn on the Map? When I look at the Map tab, the map shows up but no QSO points. Is there a setting somewhere I can’t find? Running in Win 11. Thanks!

It’s a frequent question—recommend looking through a few of the posts for tips on this.

Basically you just need to make sure your grid and your contacts’ grids are populated. You enter yours (turn on Expanded Mode to see it) and select a lookup service to populate grids for your QSOs.

Each lookup service has pros and cons. QRZ requires a paid subscription, and the others are limited in the countries used as sources for the grid square.

1 Like

Aha! There’s the missing piece of info! I haven’t been filling in the contact grid square.
Thank you for the answer!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.