Is 0.10.4 update avail in AppStore?

I am trying to update HAMRS for my Fire Tablet platform. Is the latest 0.10.4 available for that device?

I can find HAMRS in Amazon, but popup says I must download it from the Play Store. I originally downloaded HAMRS from Amazon, but cannot update it from there. I cannot navigate to the Play Store on my Fire Tablet.

Finally, should I install Play Storeon my Fire Tablet for future updates? This involves installing a few APK files then installing Google Play?

Has anyone here done this successfully?

There is a native version for Fire Tablets on Amazon, and it’s the latest version - 0.10.4:

You do not need to use the google play store at all to use the Fire version. I have a single fire tablet that I test with, and it just auto-updates an 30 minutes or so after it hits the Amazon App store. You said you originally bought it from the Amazon App Store, but it’s telling you to use Google Play to update it. Did you also purchase the Android (google play) version? I’m thinking if that’s the case, the version you have installed on your fire tablet is the google play version, and not the Amazon version.


Thanks for trying to help.

The present version on my Fire Tablet is 0.10.3 My device is running the current version of Fire OS. I definitely purchased the App from using my Fire Tablet. I had have had HAMRS on my fire for more than a week and only installed Play Store yesterday, so there is no way I purchased HAMRS from Play Store.

When I return to the HAMRS listing on, there is no clickable link to download or buy, only the notation “Ships and sold by Amazon Appstore”. Amazon Appstore is clickable but goes only to a “Help” page giving instructions for returning items. There is nothing about purchasing HAMRS or any other item.

If I go directly to the Appstore using the icon on the desktop, and search for “HAMRS”, the only result is for a Classic Movies app. HAMRS is not findable in the Appstore search function.

When I manually enter the link in your message above, I am taken to a page describing HAMRS Logger. There is a notation “To use this app on your Android devices, get the Amazon Appstore app.” This notation sits immediately above an orange “Download” bar. However, clicking the bar only goes to the HAMRS reviews page, and does not download to my Fire. On that review page is a “grayed out” box that says “CURRENTLY UNAVAILABLE”. Clicking on that box does nothing. Clicking the back arrow takes me again to the screen again offering to sell the “Classic Movies” app.

To date, I have not tried to purchase or update HAMRS via the Playstore. I’m just intending to share my experience in hopes that it might help you in the future,

I might suggest that you consider adding a link in the “Help” menu to check for available updates.

For the present I am perfectly able to use version 0.10.3 on my Fire. I don’t expect you to drop everything and address this problem with my Fire Tablet. However, if anything occurs to anyone out there, please let me know.

Many thanks to all.


I’m still unable to update to 0.10.4 on my Fire Tablet. I just spent over 2.5 hours on Amazon Help Chat with 5 different people and struck out.

I was variously told that HAMRS is incompatible with Fire Tablet, that I needed to uninstall and reinstall HAMRS, that I needed to de-register and re-register my Fire Tablet.

I think it is messed up on Amazon’s end. Searching for HAMRS on Amazon Store goes to a page that insists that HAMRS must be purchased and delivered through the Amazon Appstore. However the Appstore cannot find HAMRS and something called “Classic Movies” comes up instead.

One of the suggestions from Amazon Chat was that I should uninstall my old version and then reinstall the new one. They said this was necessary because the 0.10.3 version was freeware and 0.10.4 was purchase only. I do not believe this to be true.

If I go to I can select from three options, one being Amazon App Store. This goes to There is a purchase button on this page, and above that button it says that this version is compatible with my Fire Tablet. I tried this, thinking it might be a route to an update, but I was unable to install the this product on my Fire Tablet, even following the Amazon supplied instructions— Fire Tablets: Access quick settings → Sync then go to Apps → Cloud to see your newly purchased app to download and install. Apparently HAMRS is not sent to the Fire Tablet by this route, but makes it downloadable from the Cloud.

But this did not work for me, either, and I eventually had to ask that the new purchase be canceled.

I have no problem with purchasing HAMRS once, twice or three times, maybe more. I have it now on three devices. In fact, I think that the $5 asking price is too low. It’s worth a lot more to me than that. I’d gladly pay that again for the upgrade.

And being unable to update HAMRS on my Fire Tablet is at most a small inconvenience. The last version is working just fine for me.

But I hope that other interested parties are not having similar problems and avoiding a great product.

I’m not writing this so that Jarrett will drop everything and work on this issue. But I do want him to be aware that I think Amazon has his product registration and sales messed up.

Many thanks, and
All the best.


Man that is really really weird. Definitely don’t purchase it again. Did you sign up to be a Beta Tester for HAMRS? I wonder if that might be related. I think uninstalling and reinstalling might be the way to go, but I want to see if I can generate a promo code so you don’t have to purchase it again.

The Amazon store is such a weird half-assed closed system, it’s hard to read on what’s going on, which is a shame because the Fire tablet and Bluetooth keyboard I purchased to test with is quickly becoming my go-to for HAMRS because it’s so dang small.

I think with you spending so much time talking to Amazon Help Chat I owe you a t-shirt!


I did buy it again, but it didn’t help. I really don’t mind the $5.

The purchase screen says the HAMRS app is on the cloud and that i need to download it from there.

I can find no reference to “Cloud” on my Tablet. But I found on the web that I can go to to access and download my purchased apps.That I did, but after I signed in, HAMRS is still not there. Wondering if I need to find Cloud app somewhere and install that first.

Web also says I can find my purchased apps in Library, but I haven’t located that either.

I did not sign up to be a Beta tester, but I would be happy to report my findings back. Like you my Tablet has become my go to for POTA activations.

FWIW KZ3L is my neighbor. We do a lot of activations together.