No ADI Extension

I have been getting a lot of POTA logs recently produced by HAMRS that do not have the .adi extension. They are all v 1.0.6 and appear to be using the POTA template. Somehow, I honestly doubt these users are purposefully deleting the .adi extension when emailing the logs.
Is it possible there is some kind of bug that is no longer automatically including the .adi extension when performing the adi export?

Looking at my logs, it looks like I get no .adi when I export from my iPad.


@K2ERK When you export from your iPad, are you exporting into an email or into your Files?

Both of my iPads automatically add the .ADI extension regardless of export method. I’m not sure I can even delete or change that extension without editing the file name later, after exporting and saving it. See images below.

Windows WILL allow you to remove the extension, but it is provided by default.

I don’t know how Android works as I don’t have an Android device.

@WA7SKG, do you have any way to determine what operating system those log were generated from? Could you ask the activators?

I am exporting to Files, not emailing.
I don’t have my iPad with me now but I did just try from my iPhone and it did add the .adi extension when I tried exporting to files and to email.

It has been really busy lately and I am processing 30-60 logs every day. I honestly did not make note of whose logs had the errors. I just added the .adi extension and processed them. I did take a quick look to see if the header was HAMRS and to see if they used the POTA template (I determined that by the presence of the MY_STATE entry, which generally is not there unless they use the POTA template). The users OS is not identified in the header information, so no idea. I’ll try to make note of the activator in the future.

I’ve exported to Files on my device and to an external server (NextCloud, which is my home-brew and self-hosted “Dropbox”) and it always adds the extension. So if you are able to verify this please do so.

Yeah, those darn activators are just having too much fun! :smiley: Keeps you pretty busy, for sure. Thanks for your consistently hard work.

If you’re able to determine the source of the glitch that would certainly help narrow the scope in the hunt for a fix.

The last two logs from my iPhone did not have the .ADI extension on them, one from today, one from yesterday.

When you go to export the log to your Files, would you mind taking and posting a screen shot as I did above?

Is this a random occurrence then? Strange…

Looks like I have my issue worked out, the extension is actually there, just not showing up. Does not seem to be HAMRS related.

1 Like

Glad you got this sorted out and thanks for the update.

@WA7SKG Hopefully you will be able to get some insight from a couple of the activators you support.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.