QRZ Lookup Function Does Not Work

I am a premium member of QRZ. When I select the Lookup Function for a QSO, QRZ will not populate the fields. I initially thought the problem was related to an updated HAMRS revision, however, this function has not worked for the past three software updates. I currently have 1.0.5 installed.

Its not that important of a feature for me but it is interesting to see the map.

Tom W4ID

Did you enter your user name and password for QRZ under profile, manage profile and then enable lookup under settings? I have used every version including beta testing and it has always worked if set up properly.

Thanks Steve for your reply. Yes, I have QRZ set up in the profile and HAMRS show QRZ.com as my selected source and I did enter my QRZ user name and password.

During one of the upgrades HAMRS didn’t want to recognize my password for QRZ. Please just confirm you have a green check mark next to yours, if you don’t mind.

A couple of other ideas. Sorry if these seem basic, but sometimes they work for things like this:

  • Try rebooting your device and restarting HAMRS to see if anything changes.
  • If using a mobile device, ensure you have reliable access to the Internet
  • On that same device, try accessing QRZ.com through your browser to confirm it is online.

Since it hasn’t worked for you in quite some time, I doubt any of those are the issue, but ya never know.

If your main interest is in retrieving grid square info, try temporarily switching to HamDB. That retrieves grid squares, too.


You broke the code…THANKS!!! I have HAMRS on six devices. Five of the devices had the green check marks as in your post. The sixth, my field use hp laptop, did not although it showed QRZ as my selected integration. Going back into the Edit Profile menu, the QRZ Username and QRZ Password block were still in red. Made the correction and now the QRZ lookup function works as advertised.

The older I get, sometimes I can’t see the forest through the trees! :blush:


Perfect! Glad we were able to get this resolved. :smiley:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.