QSO Map not working on last activation

I enjoy using the QSO map and it has been working fine for all my activations so far. But on my latest activation of 32 contacts, it will only show one qso. How do I make all qso’s show up. Using Ipad mini.
Thank you in advance!!!
ka9gou

Same here. I had this issue for a week or so. Registered HAMSRS to QRZ account then it worked. Now back to no mapping.

Had a similar issue. The QSO map works on my iPhone but not on my shack PC???

It’s the grid square section. I figured out if I TAB through the “their park” section it erases the grid square which makes them not show up on the map. I have not figured out a way around it except to click on the time section instead of using the tab button.

Same here. I have a friend using iPad no issue. I am using iPhone. My grid at activation was EM84hv.

Depending upon my weight capacity or availability, I use either an iPad or iPhone for logging and both having an app build # of 0.11.6. On both I have selected QRZ as my Default Look Up Service. I am not a paid member of QRZ, but have entered my username and password.

I have not seen any lines on the map before today. Today I activated a park using my iPhone and of the 13 entries 3 showed a line to their location. The other 10 were absent.

I’m not sure what was different with those 3 entries to cause them to display.

Thanks
Edmo - K5KMY
Central Arkansas

We’re the three entries park-to-park QSOs? If so, HAMRS inserted the park grid squares instead of attempting to retrieve the op’s home QTH from QRZ.

Otherwise, perhaps QRZ burped and gave up the grid square even though you aren’t a premium subscriber. :slight_smile:

Yes, these 3 were park-to-park contacts…

Is there a way I can get the “lines” to non park-to-park contacts?

Edmo

HAMRS needs to know the other party’s grid square in order to populate the map, and it retrieves it from the lookup service you selected.

HAMRS can only retrieve grid square info from QRZ if you are a premium (paid) subscriber. Since you are not, you will need to use one of the other lookup services to populate the contact’s grid square. I use HamDB with great success.

You can also look them up from QRZ and manually enter the grid square into each QSO, but that’s not very convenient. I do look up a call sign and grid square on occasion only when HamDB doesn’t have a record of the other party (e.g. most DX call signs).

For your existing log, you can switch lookup services, then hit the gear button next to each QSO and select “Lookup” from the menu. You will need to do this for every QSO entry if fixing it retroactively.

Alternatively, choose “edit” from that same drop down menu and manually enter the other party’s grid square.

Why does their grid not get entered automatically? None of mine show grids so I must look them up and enter them manually? What does lookup do? or is this a bug?

You need to select a lookup service first to retrieve the grid squares. Which one are you using?

I changed from QRZ to HAMDB and did lookup gain and it worked. Thanks

Awesome. Thanks for closing the loop.

For anyone else reading this thread, you choose your lookup service in the Settings menu:

…and log into the relevant service via your Profile (for instance, if you are a premium QRZ subscriber).