The Map does not show the Ham Location

I have logged the HUNTER QSO’S after setting up my profile with QRZ, set in the grid square call sign, state and country.

The map does show the stations worked BUT NO home location of my call sign
nor the lines connecting my QTH with the QSO;s

Do I need to set it up with HAMQTH? or is this just another server like QRZ ??

Thank you.
73 Jean rodolphe KB2T in San Diego, CA

Grid squares for both locations are sufficient to connect the pins, but you need to ensure they’re both present for every QSO. Please see response in your other thread and continue the conversation there.

Go into settings and turn on Expanded Mode. Then enter your grid square in the right had panel.
73 and POTA On,
Charlie - K0LAF

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.