Contact not saving, having to restart HAMRS

I ran into an issue several times yesterday while out potaing :smile:

After selecting contact from the spots and copying the data into the contact fields I would clear the data as I was not able to get through the pile up. I would do some regular contact but then when I went back and tried to do a park to park by copying the spot after clicking save it would not add to my contact list. I tried saving several times to save the contact and had to restart the app to get it to save the copied contact to the log

iPad 15.2.1
HAMRS 1.0.0

I had problems logging QSO’s today as well unfortunately. I would put the call in and signal reports and hit enter and it would not log the QSO. Tried 1 call 3 separate times and it would not work. Had to close it and relaunch it on the iphone and once I did that I was able to log the call. Unfortunately I thought I had logged several QSO’s and they were never entered into my log. A new problem on the new version ; (


I had this problem today also, almost 2 hours into my activation.

I was using an iPad mini version 4 running OS 15.3 with the latest HAMRS 1.0.0 I have been using this HAMRS version since its release, for about 8-10 activations without having this problem until today.

I was on 10 meters and looking for a QSO on that band. Was probably there with my frequency pre-filled in for 30 minutes or so and finally heard a CW QSO to answer, before I could make a QSO. I typed in his call sign and the RSTs and hit enter on the screen. This was not a copied Spot, but was entered manually. The entry boxes erased, but the QSO did not save. I re-entered it 3 or 4 times via the keyboard, and it still wouldn’t save . I tried 3 more times entering the call sign and the RSTs via the touch screen and still no dice. Fortunately this time I had the Entries page open below and I noticed it immediately.

I powered off the iPad and was able to then enter the data with the keyboard and also to save it. Everything seemed to be working normally.

Then about 45 minutes later, I had been on 30m and switched to 60m, which was a lot busier. I entered 5 or 6 QSOs with the 60m frequency entered before I realized that none of my 60 meter QSOs had saved. I again powered off and restarted. The screen had reverted to the (previous) 60m frequency 5.332 and there were no saved 30m QSOs. However, I was able to log the rest of my QSOs from that time on until I went QRT-- 45 more minutes.

I usually keep my my lower screen on POTA Spots rather than on Entries, so if the QSOs aren’t being saved, it could go on for a while before that problem gets noticed. That’s how I lost the QSOs this time.

Hope this helps. That’s as much detail as I can remember, but feel free to ask questions…


After writing the post above, I went to manually (retrospectively) enter 3 QSOs into the log referenced above.

It happened again–for the 3rd time today. Data entry would not save until I closed out HAMRS and re-opened it.

I wonder if this problem could have something to do with HAMRS sitting open and untouched without any entries for (maybe) 10 or more minutes? Could this be the common denominator?

As far as I can tell, this problem does not self repair after any reasonable interval.

Jack N8EU

Thanks for the write up, that was super helpful! I think it’s a combination of too-optimistic persistence before clearing the fields and initializing a new QSO, as well as the database connection becoming stale after a lot of idle time, and it not reconnecting properly. This is my main focus now, I think I’ll have a fix for it, but not for 1.0.1, it’ll be 1.0.2 and will be released as soon as it’s complete, hopefully a few days.

1 Like

I had same experience as the others above. POTA activation, vers. 1.0.1 iPad Pro

Did rebooting your iPad at least temporarily resolve this problem?

Completely closing and reopening the app fixed it. Did not have to reboot iPad

It happened near the end of my activation, only happened once

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.